>
>
>
V815. Decreased performance. Consider r…


V815. Decreased performance. Consider replacing the expression 'AA' with 'BB'.

The analyzer has detected a construct that can be optimized: in string classes, operators are implemented that allow more efficient string clearing or checking a string for being empty.

For example:

bool f(const std::string &s)
{
  if (s == "")
    return false;
  ....
}

This code can be improved a bit. The object of the 'std::string' class knows the length of the string it is storing, but it is unknown which string it is intended to be compared to. That's why a loop is called for string comparing. A much easier and better way is to simply check that the string length is 0 - it can be done with the help of the 'empty()' function:

if (s.empty())
  return false;

A similar situation: we need to clear a string in the code fragment below, and it can be improved:

wstring str;
...
str = L"";

The better version:

wstring str;
...
str.clear();

Note. The recommendations given are arguable. Such optimizations give little benefit, while the risk is increasing of making a typo and using a wrong function. The reason for that is poor function naming. For example, the 'empty()' function in the 'std::string' class checks the string for being empty. In the class 'CString', the 'Empty()' function clears the string. The same name for both but these functions do different things. That's why you may use the constructs = "", == "", != "" to make the code more comprehensible.

The choice is up to you. If you don't like the V815 diagnostic rule, you can turn it off in the settings.